Fix Owncloud 8.1.1 samba shares not working

It never seems to go smoothly, does it? I just upgraded my version of Owncloud from 8.0.4 to 8.1.1 on my Ubuntu Trusty Tahr 14.04 VM. After the upgrade I noticed that all my samba (SMB) shares were gone. The logs were not very helpful, full of things like these:

Exception: {"Exception":"Icewind\\SMB\\Exception\\InvalidHostException","Message":"","Code":0,"Trace":"#0 \/var\/www\/owncloud\/apps\/files_external\/3rdparty\/icewind\/smb\/src\/Connection.php(37): Icewind\\SMB\\Connection

Additionally errors like this were showing up:

Your web server is not yet set up properly to allow file synchronization because the WebDAV interface seems to be broken.

After much digging I discovered this post which had a suggestion to install libsmbclient-php. In Ubuntu 14.04 it involves this command:

sudo apt-get install php5-libsmbclient

That did the trick! After installing php5-libsmbclient my samba shares worked once more.

 

3 thoughts on “Fix Owncloud 8.1.1 samba shares not working”

  1. I tried this, but no change. Than went to enable the mod (thought maybe that’s it:

    root@server:/etc/php5/mods-available# ls
    curl.ini json.ini mysql.ini pdo_mysql.ini redis.ini
    gd.ini ldap.ini mysqli.ini pdo_pgsql.ini sqlite3.ini
    imap.ini libsmbclient.ini opcache.ini pdo_sqlite.ini xsl.ini
    intl.ini mcrypt.ini pdo.ini pgsql.ini
    root@server:/etc/php5/mods-available# php5enmod libsmbclient.ini
    WARNING: Module libsmbclient.ini ini file doesn’t exist under /etc/php5/mods-available
    WARNING: Module libsmbclient.ini ini file doesn’t exist under /etc/php5/mods-available
    root@server:

    Now what?

    1. I’m not sure why you got that message. It looks like php5-libsmbclient isn’t properly installed. Maybe try and apt-get purge and try again?

Leave a Reply

Your email address will not be published. Required fields are marked *